Snowflake freshness is delayed

Incident Report for Allium

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 02:00 EDT

Update

The incident is resolved, and gaps of data in the affected window 16/04/2026 to 17/04/2026 (UTC) have been patched.
Posted Apr 20, 2026 - 01:34 EDT

Monitoring

Our data provider has identified the issue and systems are stable now. We're currently verifying the data in Snowflake.
Posted Apr 17, 2026 - 02:28 EDT

Update

Our data provider is still investigating and we will provide an update as soon as they have definitive findings.
Posted Apr 16, 2026 - 04:47 EDT

Investigating

Our data provider is facing compute execution errors and data is failing to be refreshed. We've escalated the issue and waiting for updates.
Posted Apr 16, 2026 - 00:07 EDT
This incident affected: Allium App (Explorer UI, Explorer Queries) and External Dependencies (Snowflake Snowflake Data Warehouse (Database)).